Cisco 881, PPPOE и тунель внутри PPPOE

Пример настройки PPPOE от провайдера EngiNET.

Провайдер в карточке абонента выдал нам логин, пароль и имя службы.

Начались танцы с бубном, после чего получился следующий рабочий конфиг

version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname c881-enginet
!
boot-start-marker
boot system flash:/c880data-universalk9-mz.153-3.M3.bin
boot-end-marker
!
!
enable secret 4 <censored>
!
aaa new-model
!
!
aaa authentication login default local line
aaa authentication enable default enable line
!
!
!
!
!
aaa session-id common
memory-size iomem 10
!
!
!
!
!
!


!
ip dhcp excluded-address 10.0.129.1 10.0.129.100
ip dhcp excluded-address 10.0.129.201 10.0.129.254
!
ip dhcp pool IntraNET
 network 10.0.129.0 255.255.255.0
 default-router 10.74.129.1
 dns-server 8.8.8.8 8.8.4.4
 lease 0 1
!
!
!
ip domain name example.net
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
!
license udi pid CISCO881-SEC-K9 sn <censored>
!
!
username root password 7 <censored>
!
!
!
!
!
ip ssh version 2
!
!
crypto isakmp policy 5
 encr 3des
 authentication pre-share
 group 16
crypto isakmp key <censored> address <censored>
!
!
crypto ipsec transform-set tunnel01 esp-3des esp-md5-hmac
 mode tunnel
!
crypto ipsec profile tunnel01
 set transform-set tunnel01
!
!
!
!
!
!
!
interface Tunnel1
 description [chief-guest-to-Msk]
 ip address 10.0.0.2 255.255.255.252
 tunnel source Dialer1
 tunnel mode ipsec ipv4
 tunnel destination <censored>
 tunnel protection ipsec profile tunnel01
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 description [IntraNET-local]
 switchport access vlan 29
 no ip address
 spanning-tree portfast
!
interface FastEthernet3
 description [cisco2900]
 switchport trunk allowed vlan 1,9,29,1002-1005
 switchport mode trunk
 no ip address
!
interface FastEthernet4
 description [EngiNET-uplink]
 ip address dhcp
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan9
 description [management]
 ip address 10.0.109.1 255.255.255.0
!
interface Vlan29
 description [IntraNET]
 ip address 10.0.129.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer1
 description [EngiNET-pppoe]
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin callback
 ppp chap hostname <censored>
 ppp chap password 7 <censored>
 ppp ipcp dns request
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 29 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 29 remark IntraNET
access-list 29 permit 10.0.129.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 transport input ssh
 transport output all
line vty 5 15
 transport input ssh
 transport output all
!
!
end

Из особенностей:

  • само имя службы так и не использовали
  • на Fa4 необходимо было настроить получение айпишки по дхцп (ip address dhcp)

З.Ы.

Вообще-то возможно кому-то пригодиться. Если у провайдера есть жесткая привязка к этому самому имени службы, то необходимо выполнить следующее:

interface FastEthernet4
    pppoe-client dial-pool-number 1 service-name "xxx"

где xxx и есть то самое имя службы.

 

 
comments powered by Disqus